Better Business Bureau

System status

API Processing Delays
Incident Report for BBB
Resolved
IABBB IT has resolved the issue with the delays in API messaging.  All API queues are clear. 03/18/2024 - 11:20 am EDT
Posted Mar 18, 2024 - 11:21 EDT
Monitoring
We are experiencing delays in the processing of API messages at this current time. IABBB IT is working to speed up the processing of the backlog of messages and hope to clear the queues by midday. Until that time, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org.  03/18/2024 - 9:35 AM EDT
Posted Mar 18, 2024 - 09:34 EDT
This incident affected: Data Transfer.