Better Business Bureau

System status

Customer Reviews - Star Rating Next to Each Review
Incident Report for BBB
Resolved
The issue with Star ratings next to each customer review has been resolved.
Posted Mar 21, 2024 - 11:48 EDT
Investigating
IABBB IT is investigating an issue with Star Ratings missing next to each Customer Review within business profiles. The total Customer Review Rating for the business is unaffected.
Posted Mar 21, 2024 - 09:34 EDT
This incident affected: Bbb.org.