Better Business Bureau

System status

Customer Review Verification Emails
Incident Report for BBB
Resolved
This issue has been resolved with a fix just deployed to BBB.org.
Posted Mar 22, 2024 - 15:37 EDT
Investigating
IABBB IT is currently investigating issues with Customer Review Verification emails being sent initially and also with the verification process when a resend of an email is sent from blue.
Posted Mar 21, 2024 - 11:44 EDT
This incident affected: Bbb.org.