Better Business Bureau

System status

BBB.org/Search - Slow Performance

Incident Report for BBB

Resolved

This issue is resolved. IABBB IT will continue to monitor performance.
Posted Jun 10, 2025 - 09:59 EDT

Monitoring

IABBB has identified the issue with latency and will continue to monitor performance.
Posted Jun 09, 2025 - 16:30 EDT

Investigating

IABBB IT is currently investigating latency with BBB.org/Search.
Posted Jun 09, 2025 - 15:58 EDT
This incident affected: Bbb.org.