Better Business Bureau

System status

BBB.ORG/APPLY - Accreditation API - Delays
Incident Report for BBB
Resolved
The issue with data transfer of application submissions to blue has been resolved. Applications that were held up in the system should be transmitting to blue shortly.
Posted Mar 13, 2024 - 16:41 EDT
Investigating
IABBB IT and Interactive Blue are investigating an issue resulting in a delay in Universal Accreditation Applications being received in blue. Until the issue is corrected, the receipt of new applications in blue will be delayed. We hope to have this resolved as soon as possible.
Posted Mar 13, 2024 - 15:46 EDT
This incident affected: Data Transfer.