Better Business Bureau

System status

Complaints & Reviews on Business Profiles
Incident Report for BBB
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 10:01 EDT
Monitoring
Data is re-importing, and we are monitoring the results.
Posted Mar 12, 2024 - 16:08 EDT
Identified
IABBB IT has identified an issue with the disappearance of Complaints and Reviews from Business Profiles and are working right now to restore those ASAP via a re-import of data.
Posted Mar 12, 2024 - 15:33 EDT
This incident affected: Data Transfer.