Better Business Bureau

System status

Business Profile Updates - API & Database Maintenance
Incident Report for BBB
Resolved
All API queues are clear at this time and updates to business profiles made today should be live on BBB.org. If you need assistance with a business profile that has not updated, please submit a ticket to this IABBB IT queue on Service Desk: https://iabbb.atlassian.net/servicedesk/customer/portal/4/group/9/create/31   04/05/2024 - 5:15 pm EDT
Posted Apr 05, 2024 - 17:17 EDT
Monitoring
With additional database maintenance after hours Thursday night into Friday early hours, we are experiencing delays in the processing of API messages at this current time. IABBB IT is working to speed up the processing of the backlog of messages and hope to clear the queues by midday. Until that time, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org. As IABBB IT works to enhance and further optimize the database and the database queries to better handle huge volumes of reviews and complaints, we may experience periodic delays in the processing of API messages over the next few days. IABBB IT will continue to keep you posted via alerts and messaging via status.bbb.org - April 5, 2024 - 8:45 am EDT
Posted Apr 05, 2024 - 08:46 EDT
This incident affected: Data Transfer.