Better Business Bureau

System status

BBB.org - Maintenance from 5pm to 10pm EST

Incident Report for BBB

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 21:40 EST

Monitoring

IABBB IT will be performing maintenance to BBB.org between 5:00 pm and 10:00 pm EST tonight, Friday, February 13th. If any anomalies are experienced, those should resolve once maintenance is completed. Should any issues arise, please submit a ticket to Service Desk here: https://iabbb.atlassian.net/servicedesk/customer/portal/6
Posted Feb 13, 2026 - 12:00 EST
This incident affected: Bbb.org.