Better Business Bureau

System status

BBB.ORG/GET-LISTED - Users unable to Enter a Business
Incident Report for BBB
Resolved
This issue has been resolved.
Posted Mar 14, 2024 - 11:59 EDT
Investigating
IABBB IT is investigating an issue with Get Listed. Users are unable to get past Search to select or enter a business manually.
Posted Mar 14, 2024 - 09:47 EDT
This incident affected: Bbb.org.