Better Business Bureau

System status

Business Profiles with High Volume Complaints & Reviews
Incident Report for BBB
Resolved
Complaints and Reviews have been restored to business profiles containing high volume complaints and reviews. 04/06/2024 8:45 am EDT
Posted Apr 06, 2024 - 08:47 EDT
Identified
IABBB IT and Interactive Blue have identified an issue with the display of business profiles containing high volume complaints and reviews. There are approximately 24 BIDs with in excess of 10,000 complaints. Both teams are working over the weekend to restore these records and any other affected BIDs. 04/05/2024 8:00 pm EDT
Posted Apr 05, 2024 - 20:04 EDT
This incident affected: Data Transfer.