Better Business Bureau

System status

Customer Review Verifications
Incident Report for BBB
Resolved
The issue with Customer Review verifications has been resolved.
Posted Mar 25, 2024 - 17:03 EDT
Investigating
IABBB IT is investigating an issue with Customer Review Verifications via Email. Users are seeing a 500 Error when clicking the link to verify. We hope to have this issue resolved as soon as possible.
Posted Mar 25, 2024 - 10:36 EDT
This incident affected: Bbb.org.