Better Business Bureau

System status

Customer Reviews - Display on Business Profiles
Incident Report for BBB
Update
Refactoring Underway for Reviews / Complaints - We have started the work to reconfigure the way we are updating customer reviews and complaints to solve the issues we have been facing. To expedite, we will update customer reviews and complaints once a day (2am ET daily) for the next several days. Please read more about this here: https://iabbb.sharepoint.com/sites/ITNews/SitePages/Customer-Reviews---Complaints-Work-Underway-%E2%80%93-Learn-More-and-Understand-Impact.aspx
Posted Apr 25, 2024 - 10:03 EDT
Monitoring
IABBB IT is continuing to troubleshoot the display of customer reviews on business profiles. This is the team's highest priority. As we work through this process to reimport customer reviews, customer reviews may reappear and/or disappear for brief periods of time. 9:30 am EDT - 04/18/2024
Posted Apr 18, 2024 - 09:30 EDT
This incident affects: Data Transfer.