Better Business Bureau

System status

Customer Reviews/Leave a Review

Incident Report for BBB

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 12:00 EDT

Identified

The issue with Leave a Review and searches relates to non-accredited businesses only. This issue will require development work to correct, and work is in progress.
Posted Jun 25, 2025 - 09:51 EDT

Update

The issue seen when clicking the Customer Review tab and seeing an error has been resolved. The issue with bbb.org/leave-a-review not returning results on all businesses is still under investigation.
Posted Jun 24, 2025 - 13:23 EDT

Investigating

IABBB IT is currently investigating two issues related to customer reviews. 1) Although not affecting all business profiles, clicking the Customer Review tab (or page) on some business profiles returns an Error. 2) Searching bbb.org/leave-a-review by business name may return "No Results Available" for some businesses.
Posted Jun 24, 2025 - 12:22 EDT
This incident affected: Bbb.org.