Better Business Bureau

System status

NOTICE - API/Database Maintenance - Complaints and Reviews
Incident Report for BBB
Resolved
The needed maintenance on the API and Database is complete. Profiles that may have experienced an intermittent display Error have been restored.
Posted Mar 18, 2024 - 16:43 EDT
Monitoring
IABBB IT is performing a needed maintenance on the API and Database at the moment. This maintenance may affect the display of Complaints and Reviews on BBB Business Profiles for a brief period of time this afternoon. 03/18/2024 - 3:20 pm EDT
Posted Mar 18, 2024 - 15:22 EDT
This incident affected: Data Transfer.