Better Business Bureau

System status

Complaints and Reviews - BBB Business Profiles
Incident Report for BBB
Resolved
This issue has been resolved. IABBB IT will continue to monitor the performance of the databases and the import of Complaints and Reviews.
Posted Mar 08, 2024 - 14:11 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 07, 2024 - 10:02 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 07, 2024 - 09:34 EST
Monitoring
IABBB IT has identified an issue with the import of Complaint and Review data via the API, and the team is working to reimport that data right now. Until the data is reimported, BBB Business Profiles may reflect zero complaints and/or zero reviews. We hope to have this resolved as soon as possible.
Posted Mar 06, 2024 - 10:59 EST
This incident affected: Data Transfer.