Better Business Bureau

System status

Email this Business on Business Profiles
Incident Report for BBB
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 16:23 EDT
Investigating
IABBB IT is investigating an issue with the Email this Business feature post release of the Consumer Portal. Users are unable to submit an Email to the business.
Posted Mar 01, 2024 - 15:09 EST
This incident affected: Bbb.org.