Better Business Bureau

System status

DDoS Attack on BBB.org - Mitigation Ongoing
Incident Report for BBB
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 16:56 EST
Update
While BBB.org is still experiencing a DDoS attack, the mitigation efforts and security services in place have been effective. IABBB IT will continue to monitor this very closely. Should circumstances change, further notifications will be sent to BBBs.
Posted Feb 27, 2024 - 15:47 EST
Monitoring
BBB.org is experiencing a DDoS attack at the present time, which is causing intermittent service outages or slow site response. IABBB IT is monitoring this very closely and mitigation efforts are underway.
Posted Feb 27, 2024 - 15:12 EST
This incident affected: Bbb.org.