Better Business Bureau

System status

LiveChat - Issues with accessing Agent Application
Incident Report for BBB
Resolved
LiveChat.com has advised us that a fix has been implemented, and they are monitoring the results for any further issues.
Posted May 01, 2024 - 11:13 EDT
Monitoring
LiveChat.com has identified an issue with accessing the Agent Application and are working to implement a fix. Users and Agents are unable to use LiveChat at this time. 05/01/2024 - 10:35 am EDT
Posted May 01, 2024 - 10:36 EDT
This incident affected: 3rd Party (LiveChat).