Better Business Bureau

System status

Business Profile Updates - BBB.org
Incident Report for BBB
Resolved
IABBB IT's maintenance to the database is complete. API messages are being processed; however, there is a minor backlog. Once the backlog is cleared, changes since 3:45 pm EDT will be complete.
Posted Apr 04, 2024 - 16:23 EDT
Monitoring
IABBB IT and Interactive Blue are working to resolve an issue with API updates to business profiles. IABBB will be performing maintenance on the database for a period of time this afternoon. Until that maintenance is complete, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org. Any API messages sent in from 3:45pm EDT until completion of the maintenance will be held and processed at that time. April 4, 2024 - 3:45 pm EDT
Posted Apr 04, 2024 - 15:45 EDT
This incident affected: Bbb.org.