Better Business Bureau

System status

BBB.ORG/APPLY - Application Process
Incident Report for BBB
Resolved
IABBB IT has resolved an issue with the application process that was an isolated issue. The abnormality that occurred was not a systemwide problem or occurrence.
Posted Feb 07, 2025 - 12:15 EST
Identified
IABBB IT has identified and is working to resolve an issue with the application process preventing users from progressing past Step 2. This issue should be resolved very soon.
Posted Feb 07, 2025 - 09:37 EST
This incident affected: Data Transfer.