Better Business Bureau

System status

BBB Business Profiles - Chicago Service Area
Incident Report for BBB
Resolved
This issue has been resolved.
Posted Jan 22, 2024 - 17:01 EST
Identified
IABBB IT is working to resolve an issue with BBB Business Profiles for Chicago's service area to deliver a 404 Error. This will impact users attempting to view Standard, Single, and Local business profiles delivered by the Chicago BBB.
Posted Jan 22, 2024 - 16:28 EST
This incident affected: Bbb.org.