Better Business Bureau

System status

BBB Scam Tracker - Users unable to submit scam reports
Incident Report for BBB
Resolved
The issue with users being unable to submit scam reports has been resolved.
Posted Feb 14, 2024 - 14:39 EST
Investigating
IABBB IT is currently investigating reports that users are unable to submit scam reports.
Posted Feb 14, 2024 - 13:29 EST
This incident affected: Bbb.org.