Better Business Bureau

System status

API Processing Delays
Incident Report for BBB
Resolved
This incident has been resolved.
Posted May 13, 2024 - 08:53 EDT
Update
All API queues are clear. IABBB IT and Interactive Blue will continue to monitor the API process to make sure the queues remain clear and to make sure the processes remain efficient and speedy. If you need to report a BID that has not updated, please submit a Service Desk ticket via the portal here: https://iabbb.atlassian.net/servicedesk/customer/portals 05/06/2024 - 11:30 AM EDT
Posted May 06, 2024 - 11:31 EDT
Update
We are experiencing delays in the processing of API messages at this current time. IABBB IT is working to speed up the processing of the backlog of messages and hope to clear the queues by late morning to midday. Until that time, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org. 05/06/2024 - 9:35 AM EDT
Posted May 06, 2024 - 09:37 EDT
Update
All API queues are clear. IABBB IT and Interactive Blue will continue to monitor the API process to make sure the queues remain clear and to make sure the processes remain efficient and speedy. If you need to report a BID that has not updated, please submit a Service Desk ticket via the portal here: https://iabbb.atlassian.net/servicedesk/customer/portals 04/30/2024 - 12:45 PM EDT
Posted Apr 30, 2024 - 12:48 EDT
Update
The API queue is still backlogged at the current time. IABBB IT is working to speed up the processing of the backlog of messages and hope to clear the queues by end of day. Until that time, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org. 04/29/2024 - 1:55 PM EDT
Posted Apr 29, 2024 - 13:56 EDT
Monitoring
We are experiencing delays in the processing of API messages at this current time. IABBB IT is working to speed up the processing of the backlog of messages and hope to clear the queues by early to mid-afternoon. Until that time, updates made to BBB Business Profiles will take longer than expected to display live on BBB.org.  04/29/2024 - 11:05 AM EDT
Posted Apr 29, 2024 - 11:06 EDT
This incident affected: Data Transfer.